Excel Eğer Fonksiyonu Kullanımı

EĞER işlevi

Excel’in en popüler işlevlerinden biri olan EĞER işlevi, bir değer ile beklediğiniz değer arasında mantıksal karşılaştırmalar yapmanıza olanak tanır.

Dolayısıyla, EĞER deyiminin iki sonucu olabilir. İlk sonuç karşılaştırmanızın Doğru olması, ikinci sonuç da karşılaştırmanızın Yanlış olmasıdır.

Örneğin, =EĞER(C2=”Evet”,1,2) formülü EĞER(C2 = Evet ise 1 döndür, değilse 2 döndür) demektir.

Basit EĞER örnekleri

D2 hücresindeki formül: =EĞER(C2="Evet",1,2)
  • =EĞER(C2=”Evet”,1,2)

Yukarıdaki örnekte, D2 hücresi şunu söylüyor: EĞER(C2 = Evet, o zaman 1 döndür, değilse 2 döndür)

D2 hücresindeki formül: =EĞER(C2=1,"EVET","HAYIR")
  • =EĞER(C2=1,”Evet”,”Hayır”)

Bu örnekte D2 hücresindeki formül şunu söylüyor: EĞER(C2 = 1 ise Evet döndür, değilse Hayır döndür)Sizin de gördüğünüz gibi EĞER işlevi hem metinleri hem de değerleri değerlendirmek için kullanılabilir. Ayrıca bu işlevi hataları değerlendirmek için de kullanabilirsiniz. Yapabilecekleriniz bir öğenin başka bir öğeyle eşit olup olmadığına bakmak ve tek bir sonuç döndürmekle sınırlı değildir; matematiksel işleçler kullanabilir ve ölçütlerinize bağlı olarak ek hesaplamalar gerçekleştirebilirsiniz. Bunun dışında, birkaç EĞER işlevini iç içe kullanarak birden çok karşılaştırma da yapabilirsiniz.

D2 hücresindeki formül: =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)
  • =EĞER(C2>B2,”Bütçeyi Aşıyor”,”Bütçe İçinde”)

Yukarıdaki örnekte, D2 hücresindeki EĞER işlevi şunu söylüyor: EĞER(C2 B2’den Büyükse, o zaman “Bütçeyi Aşıyor” metnini döndür, değilse “Bütçe İçinde” metnini döndür)

E2 formülündeki hücre: =EĞER(C2>B2,C2-B2,"")
  • =EĞER(C2>B2,C2-B2,0)

Yukarıdaki çizimde, Metin sonucu yerine matematiksel bir hesaplama döndüreceğiz. Dolayısıyla E2’deki formül şunu söylüyor: EĞER(Gerçek Değeri Bütçelenen Değerinden Büyükse, o zaman Bütçelenen tutarı Gerçek tutardan çıkar, değilse hiçbir şey döndürme).

F7 hücresindeki formül: EĞER(E7=”Evet”,F5*0,0825,0)
  • =EĞER(E7=”Evet”,F5*0,0825,0)

Bu örnekte F7’deki formül şunu söylüyor: EĞER(E7 = “Evet”, o zaman F5 * %8,25’te Toplam Tutarı hesapla, değilse süresi geçmiş Satış Vergisi yoktur bu nedenle 0 döndür)

Not: Formüllerde metin kullanacaksanız, metni tırnak içine almalısınız (örneğin, “Metin”). Bu kural yalnızca DOĞRU ve YANLIŞ sözcükleri için geçerli değildir; Excel bu sözcükleri otomatik olarak anlar.

Sık karşılaşılan sorunlar

SorunNerede sorun çıktı
Hücrede 0 (sıfır) varEğer_doğruysa_değer ve eğer_yanlışsa_değer bağımsız değişkenlerinden biri yoktur. Döndürülen doğru değeri görmek için, iki bağımsız değişkene de bağımsız değişken metni ekleyin veya bağımsız değişkene DOĞRU veya YANLIŞ ekleyin.
Hücrede #AD? varBu çoğunlukla formülde yazım hatası olduğu anlamına gelir.

—Ekler—

Paylaş

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

Menü
Giriş